Qt 4.6 et Mac OS X : adieu Panther
Bienvenue Snow Leopard

Le , par dourouc05, Responsable Qt
Bonjour,

Hier, le repository Qt a subi quelques changements : principalement, la création de la branche 4.6-stable ! http://qt.gitorious.org/qt/qt/commits/4.6-stable

Cette version 4.6 apporte de nombreuses nouveautés, mais aussi marque la suppression de systèmes anciens. Le support de Win9X avait été enlevé de Qt 4.5. Maintenant, c'est au tour du port Mac OS X de se voir délesté : après l'arrêt du support de GCC 3.3 de Qt 4.5, qui empêche la compilation du framework sur Panther (10.3), c'est désormais l'exécution sur la plateforme qui n'est plus supportée ! A contrario, le support de la dernière version, Snow Leopard (10.6) est annoncé.

Concrètement, qu'est-ce que cela va changer ?

  • Du point de vue du client, Mac OS X Panther ne sera plus du tout supporté.
  • Du point de vue du développeur, il pourra développer pour des systèmes plus récents (Qt sera compilé par défaut en 64 bits pour Snow Leopard).
  • Du point de vue des mainteneurs de Qt, ce sont des franges entières de code qui vont être abandonnées, et du temps pour le test de plateformes récentes.
Cependant, il reste encore bien des possiblités pour Mac OS X : trois versions du système sont supportées (10.4, 10.5 et 10.6), deux librairies (Carbon et Cocoa), mais aussi quatre architectures (PPC, PPC64, i386, AMD64 / x86_64) !

Ceci fait que les développeurs ont beaucoup de travail lorsqu'il faut s'assurer que tout fonctionne. Ainsi, de nombreuses combinaisons vont être abandonnées dans les prochaines versions. Par exemple, PPC64 n'est plus supporté par GCC.

Il est toujours possible d'utiliser le port pour Carbon, mais il ne sera plus par défaut sur les plateformes 32 bits dès la version 4.7 de Qt. Dès la version 4.8, il n'existera plus. En même temps, le support de Qt3 et de Tiger (10.4) seront abandonnés.

Il en résultera un framework plus léger, plus simple à maintenir, plus performant.

Source : http://labs.trolltech.com/blogs/2009...on-mac-os-106/

Que pensez-vous de toutes ces plateformes qui ne sont ou ne seront plus supportées ?

Est-il encore envisageable de supporter les premières versions de Mac OS X (Panther étant sorti en 2003) ? Est-ce encore utile ?
Souffrirez-vous de l'absence de support pour Panther ?

Concernant le futur : est-ce une bonne idée d'effacer le support de Carbon ? Ce framework est-il encore souvent utilisé ? La majorité des utilisateurs supportent-ils Cocoa ? Peut-on oublier le peu qui ne peuvent le supporter ?


Vous avez aimé cette actualité ? Alors partagez-la avec vos amis en cliquant sur les boutons ci-dessous :
Offres d'emploi IT
Technicien (ne) de proximité / poste de travail - Windows / Mac - Paris (H/F)
Synchrone technologies - Ile de France - Paris (75009)
Data science / machine learning engineer
Pulpix - Ile de France - Paris (75000)
Développeur react js et amateur de machine learning H/F
Bluecoders - Ile de France - Paris (75000)

Voir plus d'offres Voir la carte des offres IT
Contacter le responsable de la rubrique Mac